Server Lag

icecosmicuprise

Nation Builder
Donor Level 2
#1
Okay so I've been getting a lot of server lag for the past couple of weeks now. When i die it takes about 20-30 seconds to open up a chest, chat, Etc. When i go in and out of the nether i have the same problem aslo when i first log in i have it as well. I'm not for sure if its just me but i have tried Restarting my modem and other things. How can i fix this?
 
#2
When the server first reset I had the same problem. I resorted to lowering a couple settings. Chunk load I put down to 8, I lowered the fps, and I changed the shading to minimum too. Haven't really had any problems since. I would suggest messing with the settings a little and see if it makes a difference. you may not have to go as low as I did. Hope this helps

~Foose
 

fffizzz

Administrator
Adman
#3
Unfortunately, the increased entity count and complex chunk generation places extra load on the cpu. I'd recommend optifine as well as it can drastically improve performance.
 

Tercept

Administrator
Adman
Donor Level 5
#5
Already tried that i have optifine and sadly i still have the same problem :/
It could be players being too close to generated land like the redstone islands. That causes a huge amount of lag.

Just try to reduce entity counts by keeping small numbers of farm animals, less flowing water/lava, and less redstone being used.
 
#6
It could be players being too close to generated land like the redstone islands. That causes a huge amount of lag.

Just try to reduce entity counts by keeping small numbers of farm animals, less flowing water/lava, and less redstone being used.
You keep saying 'being close to the redstone islands' but if they are such a problem, why not delete them or WE them into stone? No offence ;)
 

icecosmicuprise

Nation Builder
Donor Level 2
#8
Now it only takes about 5-7 seconds to load up everything insted of 20-30 seconds i have no idea what i did i just turned on my computer and it works now the only thing i changed was some settings and added a texture pack and it takes a lot less now to load which i like i can put with 5 seconds to load :)
 
#9
Cause it causes so much lag to even get that close.
Oh lol, can't you just close the server, then make a backup of it and the map, download it and then do it via MCedit, the one that isn't ingame (
).
((I don't know if thats up to date to the MC version atm tho))
And then upload it again and open the server again. That might work, not sure tho
 

Tercept

Administrator
Adman
Donor Level 5
#10
Oh lol, can't you just close the server, then make a backup of it and the map, download it and then do it via MCedit, the one that isn't ingame (
).
((I don't know if thats up to date to the MC version atm tho))
And then upload it again and open the server again. That might work, not sure tho
I could however everyone would lose their progress from the time it takes to edit the map and then re upload.

The map is over 8GB. That would take me a few hours to download and it would take days for me to re upload.
 
#11
Most of the redstone, diamond, lapis, emerald, glowstone that there was an extreme amount of has been WE out, as there are areas that we have not found yet, we will continue to WE any that we can find, some other issues that causes lag is large amount of water and lava falling, if you come to an area that has this just pm me and I'll come stop most of witch I can find if the lag is to much for you. If you do come to an area that is just to much and causes to much lag, just create a ticket /ticket open (text) , please do this at the location where you get the lag the most so we can get to it faster, and please tell us what the lag seems to be coming from, and I will do the best I can to fix the issue
 
Top